media-gfx/splash-themes-livecd: Merge gentoo-functions use fix
[gentoo.git] / app-accessibility / nfbtrans / nfbtrans-7.74-r1.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="3"
6
7 inherit eutils
8
9 DESCRIPTION="braille translator from the National Federation of the Blind"
10 HOMEPAGE="http://www.nfb.org/nfbtrans"
11 SRC_URI="http://www.nfb.org/Images/nfb/Products_Technology/nfbtr774.zip"
12
13 LICENSE="public-domain"
14 SLOT="0"
15 KEYWORDS="amd64 ~ppc x86"
16 IUSE=""
17
18 DEPEND=" >=app-arch/unzip-5.50-r2"
19 RDEPEND=""
20
21 S=${WORKDIR}
22
23 src_prepare() {
24         mv MAKEFILE Makefile
25         mv SPANISH.ZIP spanish.zip
26         make lowercase || die
27         epatch "${FILESDIR}"/${P}-gentoo-fix.patch
28         epatch "${FILESDIR}"/${P}-getline-fix.patch
29 }
30
31 src_compile() {
32         make CC=$(tc-getCC) \
33                 LIBS= \
34                 CFLAGS="${CFLAGS} -DLINUX" LDFLAGS="${LDFLAGS}" all || die
35 }
36
37 src_install() {
38         dobin nfbtrans || die
39         dodoc *fmt readme.txt makedoc
40         insinto /etc/nfbtrans
41         doins *cnf *tab *dic spell.dat *zip
42 }