app-accessibility/speech-dispatcher: stable 0.8.7 for ia64, bug #631656
[gentoo.git] / app-accessibility / epos / epos-2.5.37-r2.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit eutils autotools
7
8 DESCRIPTION="language independent text-to-speech system"
9 HOMEPAGE="http://epos.ure.cas.cz/"
10 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 x86"
15 IUSE=""
16
17 DEPEND=">=app-text/sgmltools-lite-3.0.3-r9
18         dev-util/byacc"
19 RDEPEND=""
20
21 src_prepare() {
22         epatch "${FILESDIR}"/${P}-gcc43.patch \
23                 "${FILESDIR}"/${P}-gcc45.patch \
24                 "${FILESDIR}"/${P}-gcc47.patch \
25                 "${FILESDIR}"/${P}-disable-tests.patch
26
27         sed -i -e "s/CCC/#CCC/" configure.ac || die
28
29         eautoreconf
30 }
31
32 src_configure() {
33         econf \
34                 --enable-charsets \
35                 --disable-portaudio \
36                 YACC=byacc
37 }
38
39 src_install() {
40         default
41
42         doinitd "${FILESDIR}/eposd"
43         dodoc WELCOME THANKS Changes "${FILESDIR}/README.gentoo"
44 }