04453440fea466d851749b53721fc3d184c079b6
[gentoo.git] / app-accessibility / at-spi2-atk / at-spi2-atk-2.30.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit gnome.org meson multilib-minimal virtualx xdg
7
8 DESCRIPTION="Gtk module for bridging AT-SPI to Atk"
9 HOMEPAGE="https://wiki.gnome.org/Accessibility"
10
11 LICENSE="LGPL-2+"
12 SLOT="2"
13 KEYWORDS="alpha amd64 arm arm64 ~hppa ~ia64 ~mips ~ppc ppc64 s390 ~sh ~sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
14 IUSE="test"
15
16 RDEPEND="
17         >=sys-apps/dbus-1.5[${MULTILIB_USEDEP}]
18         >=dev-libs/glib-2.32:2[${MULTILIB_USEDEP}]
19         >=dev-libs/atk-2.30.0[${MULTILIB_USEDEP}]
20         >=app-accessibility/at-spi2-core-2.30.0[${MULTILIB_USEDEP}]
21 "
22 DEPEND="${RDEPEND}
23         virtual/pkgconfig[${MULTILIB_USEDEP}]
24         test? ( >=dev-libs/libxml2-2.9.1 )
25 "
26
27 multilib_src_configure() {
28         meson_src_configure
29 }
30
31 multilib_src_compile() {
32         meson_src_compile
33 }
34
35 multilib_src_test() {
36         virtx dbus-run-session meson test -C "${BUILD_DIR}" || die 'tests failed'
37 }
38
39 multilib_src_install() {
40         meson_src_install
41 }