Merge remote-tracking branch 'github/pr/2627'
[gentoo.git] / app-accessibility / accerciser / accerciser-3.22.0.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=6
6 PYTHON_COMPAT=( python{3_4,3_5} )
7 PYTHON_REQ_USE="xml"
8
9 inherit gnome2 python-r1
10
11 DESCRIPTION="Interactive Python accessibility explorer"
12 HOMEPAGE="https://wiki.gnome.org/Apps/Accerciser"
13
14 LICENSE="BSD CC-BY-SA-3.0"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE=""
18
19 RDEPEND="
20         >=app-accessibility/at-spi2-core-2.5.2:2
21         >=dev-python/pygobject-2.90.3:3[${PYTHON_USEDEP}]
22         >=x11-libs/gtk+-3.1.13:3[introspection]
23
24         dev-libs/atk[introspection]
25         >=dev-libs/glib-2.28:2
26         dev-libs/gobject-introspection:=
27         >=dev-python/ipython-0.11[${PYTHON_USEDEP}]
28         >=dev-python/pyatspi-2.1.5[${PYTHON_USEDEP}]
29         dev-python/pycairo[${PYTHON_USEDEP}]
30         x11-libs/gdk-pixbuf[introspection]
31         x11-libs/libwnck:3[introspection]
32         x11-libs/pango[introspection]
33         ${PYTHON_DEPS}
34 "
35 DEPEND="${RDEPEND}
36         app-text/yelp-tools
37         >=dev-util/intltool-0.35
38         sys-devel/gettext
39         virtual/pkgconfig
40 "
41
42 src_prepare() {
43         gnome2_src_prepare
44
45         # Leave shebang alone
46         sed 's:@PYTHON@:/usr/bin/python:' -i src/accerciser.in || die
47
48         python_copy_sources
49 }
50
51 src_configure() {
52         python_foreach_impl run_in_build_dir gnome2_src_configure
53 }
54
55 src_compile() {
56         python_foreach_impl run_in_build_dir gnome2_src_compile
57 }
58
59 src_install() {
60         installing() {
61                 gnome2_src_install
62                 python_doscript src/accerciser
63         }
64         python_foreach_impl run_in_build_dir installing
65 }