sys-process/glances: revbump 3.1.4.1, add missing doc dep
[gentoo.git] / acct-user / spamd / spamd-0.ebuild
1 # Copyright 2019-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit acct-user
7
8 DESCRIPTION="User for the SpamAssassin daemon"
9
10 ACCT_USER_ID=337
11 ACCT_USER_GROUPS=( "${PN}" )
12 # The spamd daemon runs as this user. Use a real home directory so
13 # that it can hold SA configuration.
14 #
15 # Since spamd's home contains user-modifiable config files, it's
16 # a violation of the Linux FHS for it to be here, but it's been
17 # decided it can't be in /home/.
18 #
19 # - https://github.com/gentoo/gentoo/pull/14055#issuecomment-582929503
20 # - https://archives.gentoo.org/gentoo-dev/message/790294f7a46496aecd0056289c4b6d08
21 #
22 ACCT_USER_HOME="/var/lib/spamd"
23 ACCT_USER_HOME_PERMS=0700
24
25 acct-user_add_deps