net-libs/libnetfilter_queue: stable 1.0.3 for hppa, bug #726122
[gentoo.git] / acct-user / git / git-0.ebuild
1 # Copyright 2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit acct-user
7
8 DESCRIPTION="Git repository hosting user"
9
10 IUSE="gitea gitolite"
11 REQUIRED_USE="^^ ( gitea gitolite )"
12
13 ACCT_USER_ID=196
14 ACCT_USER_HOME_OWNER=git:git
15 ACCT_USER_HOME_PERMS=750
16 ACCT_USER_SHELL=/bin/sh
17 ACCT_USER_GROUPS=( git )
18
19 acct-user_add_deps
20
21 pkg_setup() {
22         if use gitea; then
23                 ACCT_USER_HOME=/var/lib/gitea
24         elif use gitolite; then
25                 ACCT_USER_HOME=/var/lib/gitolite
26         else
27                 die "Incorrect USE flag combination"
28         fi
29 }